In short
- CVE-2018-7408 is a HIGH (CVSS 7.8) vulnerability affecting npm (npmjs), npm.
- Chance of exploitation in the next 30 days (EPSS): 0.32%, higher than 25.1% of all vulnerabilities.
- Fix: update to 5.7.1 or later.
| Package | Affected versions | Patched versions |
|---|
| npm | = 5.7.0
| No fix yet |
| npm npm | < 5.7.1
| 5.7.1
|
Description
An issue was discovered in an npm 5.7.0 2018-02-21 pre-release (marked as "next: 5.7.0" and therefore automatically installed by an "npm upgrade -g npm" command, and also announced in the vendor's blog without mention of pre-release status). It might allow local users to bypass intended filesystem access restrictions because ownerships of /etc and /usr directories are being changed unexpectedly, related to a "correctMkdir" issue.
NVD description
An issue was discovered in an npm 5.7.0 2018-02-21 pre-release (marked as "next: 5.7.0" and therefore automatically installed by an "npm upgrade -g npm" command, and also announced in the vendor's blog without mention of pre-release status). It might allow local users to bypass intended filesystem access restrictions because ownerships of /etc and /usr directories are being changed unexpectedly, related to a "correctMkdir" issue.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free