In short
- CVE-2019-0194 is a HIGH (CVSS 7.5) vulnerability affecting org.apache.camel:camel-core, camel (apache).
- Chance of exploitation in the next 30 days (EPSS): 8.5%, higher than 95.0% of all vulnerabilities.
- Fix: update to 2.21.5, 2.22.3, 2.23.1 or later.
| Package | Affected versions | Patched versions |
|---|
| org.apache.camel:camel-core Maven | ≥ 2.21.0, < 2.21.5≥ 2.22.0, < 2.22.3≥ 2.23.0, < 2.23.1
| 2.21.52.22.32.23.1
|
| camel | = 2.23.0≥ 2.0.0, ≤ 2.19.0≥ 2.21.0, ≤ 2.21.3≥ 2.22.0, ≤ 2.22.2
| No fix yet |
Description
Apache Camel's File is vulnerable to directory traversal. Camel 2.21.0 to 2.21.3, 2.22.0 to 2.22.2, 2.23.0 and the unsupported Camel 2.x (2.19 and earlier) versions may be also affected.
NVD description
Apache Camel's File is vulnerable to directory traversal. Camel 2.21.0 to 2.21.3, 2.22.0 to 2.22.2, 2.23.0 and the unsupported Camel 2.x (2.19 and earlier) versions may be also affected.
More vulnerabilities in org.apache.camel:camel-core
See all →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free