In short
- CVE-2019-1000021 is a HIGH (CVSS 7.5) vulnerability affecting slixmpp, slixmpp (slixmpp project).
- Chance of exploitation in the next 30 days (EPSS): 2.3%, higher than 83.2% of all vulnerabilities.
- Fix: update to 1.4.2 or later.
| Package | Affected versions | Patched versions |
|---|
| slixmpp PyPI | < 1.4.2
| 1.4.2
|
| slixmpp | < 1.4.2
| 1.4.2
|
Description
slixmpp version before commit 7cd73b594e8122dddf847953fcfc85ab4d316416 contains an incorrect Access Control vulnerability in XEP-0223 plugin (Persistent Storage of Private Data via PubSub) options profile, used for the configuration of default access model that can result in all of the contacts of the victim can see private data having been published to a PEP node. This attack appears to be exploitable if the user of this library publishes any private data on PEP, the node isn't configured to be private. This vulnerability appears to have been fixed in commit 7cd73b594e8122dddf847953fcfc85ab4d316416 which is included in slixmpp 1.4.2.
NVD description
slixmpp version before commit 7cd73b594e8122dddf847953fcfc85ab4d316416 contains an incorrect Access Control vulnerability in XEP-0223 plugin (Persistent Storage of Private Data via PubSub) options profile, used for the configuration of default access model that can result in all of the contacts of the victim can see private data having been published to a PEP node. This attack appears to be exploitable if the user of this library publishes any private data on PEP, the node isn't configured to be private. This vulnerability appears to have been fixed in commit 7cd73b594e8122dddf847953fcfc85ab4d316416 which is included in slixmpp 1.4.2.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free