In short
- CVE-2022-45197 is a HIGH (CVSS 7.5) vulnerability affecting slixmpp, slixmpp (slixmpp project).
- Chance of exploitation in the next 30 days (EPSS): 0.51%, higher than 44.0% of all vulnerabilities.
- Fix: update to 1.8.3 or later.
| Package | Affected versions | Patched versions |
|---|
| slixmpp PyPI | < 1.8.3
| 1.8.3
|
| slixmpp | < 1.8.3
| 1.8.3
|
Description
Slixmpp before 1.8.3 lacks SSL Certificate hostname validation in XMLStream, allowing an attacker to pose as any server in the eyes of Slixmpp.
NVD description
Slixmpp before 1.8.3 lacks SSL Certificate hostname validation in XMLStream, allowing an attacker to pose as any server in the eyes of Slixmpp.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free