In short
- CVE-2019-1003015 is a CRITICAL (CVSS 9.1) vulnerability affecting org.jenkins-ci.plugins:job-import-plugin, job import (jenkins).
- Chance of exploitation in the next 30 days (EPSS): 1.8%, higher than 78.8% of all vulnerabilities.
- Fix: update to 3.0 or later.
Description
An XML external entity (XXE) processing vulnerability exists in Jenkins Job Import Plugin 2.1 and earlier in src/main/java/org/jenkins/ci/plugins/jobimport/client/RestApiClient.java that allows attackers with the ability to control the HTTP server (Jenkins) queried in preparation of job import to read arbitrary files, perform a denial of service attack, etc.
NVD description
An XML external entity processing vulnerability exists in Jenkins Job Import Plugin 2.1 and earlier in src/main/java/org/jenkins/ci/plugins/jobimport/client/RestApiClient.java that allows attackers with the ability to control the HTTP server (Jenkins) queried in preparation of job import to read arbitrary files, perform a denial of service attack, etc.
More vulnerabilities in org.jenkins-ci.plugins:job-import-plugin
See all →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free