In short
- CVE-2019-1003016 is a HIGH (CVSS 8.8) vulnerability affecting org.jenkins-ci.plugins:job-import-plugin, job import (jenkins).
- Chance of exploitation in the next 30 days (EPSS): 0.91%, higher than 59.9% of all vulnerabilities.
- Fix: update to 3.0 or later.
Description
Jenkins Job Import Plugin did not check user permissions on its API endpoint used to access remote Jenkins instances. This allowed users with Overall/Read access to Jenkins to connect to an attacker-specified URL using attacker-specified credentials IDs obtained through another method, capturing credentials stored in Jenkins.
Job Import Plugin 3.0 will only access Jenkins instances using credentials defined in the global configuration.
NVD description
An exposure of sensitive information vulnerability exists in Jenkins Job Import Plugin 2.1 and earlier in src/main/java/org/jenkins/ci/plugins/jobimport/JobImportAction.java, src/main/java/org/jenkins/ci/plugins/jobimport/JobImportGlobalConfig.java, src/main/java/org/jenkins/ci/plugins/jobimport/model/JenkinsSite.java that allows attackers with Overall/Read permission to have Jenkins connect to an attacker-specified URL using attacker-specified credentials IDs obtained through another method, capturing credentials stored in Jenkins.
More vulnerabilities in org.jenkins-ci.plugins:job-import-plugin
See all →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free