In short
- CVE-2019-1003018 is a MEDIUM (CVSS 4.3) vulnerability affecting org.jenkins-ci.plugins:github-oauth, github oauth (jenkins).
- Chance of exploitation in the next 30 days (EPSS): 1.1%, higher than 66.6% of all vulnerabilities.
- Fix: update to 0.31 or later.
Description
An exposure of sensitive information vulnerability exists in Jenkins GitHub Authentication Plugin 0.29 and earlier in GithubSecurityRealm/config.jelly that allows attackers able to view a Jenkins administrator's web browser output, or control the browser (e.g. malicious extension) to retrieve the configured client secret.
NVD description
An exposure of sensitive information vulnerability exists in Jenkins GitHub Authentication Plugin 0.29 and earlier in GithubSecurityRealm/config.jelly that allows attackers able to view a Jenkins administrator's web browser output, or control the browser (e.g. malicious extension) to retrieve the configured client secret.
More vulnerabilities in org.jenkins-ci.plugins:github-oauth
See all →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free