In short
- CVE-2019-1003019 is a MEDIUM (CVSS 5.9) vulnerability affecting org.jenkins-ci.plugins:github-oauth, github oauth (jenkins).
- Chance of exploitation in the next 30 days (EPSS): 0.85%, higher than 58.4% of all vulnerabilities.
- Fix: update to 0.31 or later.
Description
An session fixation vulnerability exists in Jenkins GitHub Authentication Plugin 0.29 and earlier in GithubSecurityRealm.java that allows unauthorized attackers to impersonate another user if they can control the pre-authentication session.
NVD description
An session fixation vulnerability exists in Jenkins GitHub Authentication Plugin 0.29 and earlier in GithubSecurityRealm.java that allows unauthorized attackers to impersonate another user if they can control the pre-authentication session.
More vulnerabilities in org.jenkins-ci.plugins:github-oauth
See all →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free