In short
- CVE-2019-1003099 is a MEDIUM (CVSS 6.5) vulnerability affecting org.jenkins-ci.plugins:openid, openid (jenkins).
- Chance of exploitation in the next 30 days (EPSS): 1.5%, higher than 74.6% of all vulnerabilities.
- Fix: update to 2.4 or later.
Description
A missing permission check in Jenkins openid Plugin in the OpenIdSsoSecurityRealm.DescriptorImpl#doValidate form validation method allows attackers with Overall/Read permission to initiate a connection to an attacker-specified server.
NVD description
A missing permission check in Jenkins openid Plugin in the OpenIdSsoSecurityRealm.DescriptorImpl#doValidate form validation method allows attackers with Overall/Read permission to initiate a connection to an attacker-specified server.
More vulnerabilities in org.jenkins-ci.plugins:openid
See all →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free