In short
- CVE-2019-10091 is a HIGH (CVSS 7.4) vulnerability affecting org.apache.geode:geode-core, geode (apache).
- Chance of exploitation in the next 30 days (EPSS): 1.4%, higher than 72.8% of all vulnerabilities.
- Fix: update to 1.10.0 or later.
Description
When TLS is enabled with ssl-endpoint-identification-enabled set to true, Apache Geode fails to perform hostname verification of the entries in the certificate SAN during the SSL handshake. This could compromise intra-cluster communication using a man-in-the-middle attack.
NVD description
When TLS is enabled with ssl-endpoint-identification-enabled set to true, Apache Geode fails to perform hostname verification of the entries in the certificate SAN during the SSL handshake. This could compromise intra-cluster communication using a man-in-the-middle attack.
More vulnerabilities in org.apache.geode:geode-core
See all →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free