In short
- CVE-2019-10349 is a MEDIUM (CVSS 5.4) vulnerability affecting org.jenkins-ci.plugins:depgraph-view, dependency graph viewer (jenkins).
- Chance of exploitation in the next 30 days (EPSS): 3.8%, higher than 90.2% of all vulnerabilities.
- Fix: update to 0.14 or later.
Description
A stored cross site scripting vulnerability in Jenkins Dependency Graph Viewer Plugin 0.13 and earlier allowed attackers able to configure jobs in Jenkins to inject arbitrary HTML and JavaScript in the plugin-provided web pages in Jenkins.
NVD description
A stored cross site scripting vulnerability in Jenkins Dependency Graph Viewer Plugin 0.13 and earlier allowed attackers able to configure jobs in Jenkins to inject arbitrary HTML and JavaScript in the plugin-provided web pages in Jenkins.
More vulnerabilities in org.jenkins-ci.plugins:depgraph-view
See all →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free