In short
- CVE-2019-16226 is a HIGH (CVSS 7.5) vulnerability affecting lmdb, py-lmdb (py-lmdb project).
- Chance of exploitation in the next 30 days (EPSS): 1.6%, higher than 75.7% of all vulnerabilities.
- Fix: update to 0.98 or later.
| Package | Affected versions | Patched versions |
|---|
| lmdb PyPI | ≤ 0.97< 0.98
| 0.98
|
| py-lmdb | ≤ 0.97
| No fix yet |
Description
An issue was discovered in py-lmdb 0.97. mdb_node_del does not validate a memmove in the case of an unexpected node->mn_hi, leading to an invalid write operation.
NVD description
An issue was discovered in py-lmdb 0.97. mdb_node_del does not validate a memmove in the case of an unexpected node->mn_hi, leading to an invalid write operation. NOTE: this outcome occurs when accessing a data.mdb file supplied by an attacker.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free