In short
- CVE-2019-16227 is a CRITICAL (CVSS 9.8) vulnerability affecting lmdb, py-lmdb (py-lmdb project).
- Chance of exploitation in the next 30 days (EPSS): 2.0%, higher than 81.2% of all vulnerabilities.
- Fix: update to 0.98 or later.
| Package | Affected versions | Patched versions |
|---|
| lmdb PyPI | ≤ 0.97< 0.98
| 0.98
|
| py-lmdb | ≤ 0.97
| No fix yet |
Description
An issue was discovered in py-lmdb 0.97. For certain values of mn_flags, mdb_cursor_set triggers a memcpy with an invalid write operation within mdb_xcursor_init1. NOTE: this outcome occurs when accessing a data.mdb file supplied by an attacker.
NVD description
An issue was discovered in py-lmdb 0.97. For certain values of mn_flags, mdb_cursor_set triggers a memcpy with an invalid write operation within mdb_xcursor_init1. NOTE: this outcome occurs when accessing a data.mdb file supplied by an attacker.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free