In short
- CVE-2019-19450 is a CRITICAL (CVSS 9.8) vulnerability affecting reportlab, reportlab (reportlab).
- Chance of exploitation in the next 30 days (EPSS): 6.0%, higher than 93.3% of all vulnerabilities.
- Fix: update to 3.5.31 or later.
| Package | Affected versions | Patched versions |
|---|
| reportlab PyPI | < 3.5.31
| 3.5.31
|
| reportlab | < 3.5.31
| 3.5.31
|
Description
paraparser in ReportLab before 3.5.31 allows remote code execution because start_unichar in paraparser.py evaluates untrusted user input in a unichar element in a crafted XML document with '<unichar code="' followed by arbitrary Python code, a similar issue to CVE-2019-17626.
NVD description
paraparser in ReportLab before 3.5.31 allows remote code execution because start_unichar in paraparser.py evaluates untrusted user input in a unichar element in a crafted XML document with '<unichar code="' followed by arbitrary Python code, a similar issue to CVE-2019-17626.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free