In short
- CVE-2019-25050 is a HIGH (CVSS 7.8) vulnerability affecting gdal, gdal (osgeo).
- Chance of exploitation in the next 30 days (EPSS): 0.35%, higher than 28.6% of all vulnerabilities.
- Fix: update to 3.1.0 or later.
| Package | Affected versions | Patched versions |
|---|
| gdal PyPI | ≥ 2.4.2, < 3.1.0
| 3.1.0
|
| gdal | ≥ 2.4.2, ≤ 3.0.4
| No fix yet |
Description
netCDF in GDAL 2.4.2 through 3.0.4 has a stack-based buffer overflow in nc4_get_att (called from nc4_get_att_tc and nc_get_att_text) and in uffd_cleanup (called from netCDFDataset::~netCDFDataset and netCDFDataset::~netCDFDataset).
NVD description
netCDF in GDAL 2.4.2 through 3.0.4 has a stack-based buffer overflow in nc4_get_att (called from nc4_get_att_tc and nc_get_att_text) and in uffd_cleanup (called from netCDFDataset::~netCDFDataset and netCDFDataset::~netCDFDataset).
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free