| Package | Affected versions | Patched versions |
|---|---|---|
| org.apache.kylin:kylin-server-base | < 3.1.0 | 3.1.0 |
| kylin | ≥ 2.0.0, < 3.1.0 | 3.1.0 |
Kylin concatenates and executes a Hive SQL in Hive CLI or beeline when building a new segment; some part of the HQL is from system configurations, while the configuration can be overwritten by certain rest api, which makes SQL injection attack is possible. Users of all previous versions after 2.0 should upgrade to 3.1.0.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free