In short
- CVE-2020-1937 is a HIGH (CVSS 8.8) vulnerability affecting org.apache.kylin:kylin-server-base, kylin (apache).
- Chance of exploitation in the next 30 days (EPSS): 3.1%, higher than 87.6% of all vulnerabilities.
- Fix: update to 3.0.1, 2.6.5 or later.
| Package | Affected versions | Patched versions |
|---|
| org.apache.kylin:kylin-server-base Maven | ≥ 3.0.0, < 3.0.1< 2.6.5
| 3.0.12.6.5
|
| kylin | = 3.0.0≥ 2.3.0, ≤ 2.3.2≥ 2.4.0, ≤ 2.4.1≥ 2.5.0, ≤ 2.5.2≥ 2.6.0, ≤ 2.6.4
| No fix yet |
Description
Kylin has some restful apis which will concatenate SQLs with the user input string, a user is likely to be able to run malicious database queries.
NVD description
Kylin has some restful apis which will concatenate SQLs with the user input string, a user is likely to be able to run malicious database queries.
More vulnerabilities in org.apache.kylin:kylin-server-base
See all →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free