In short
- CVE-2020-15125 is a HIGH (CVSS 7.7) vulnerability affecting auth0.js (auth0), auth0.
- Chance of exploitation in the next 30 days (EPSS): 1.5%, higher than 74.9% of all vulnerabilities.
- Fix: update to 2.27.1 or later.
| Package | Affected versions | Patched versions |
|---|
| auth0.js | < 2.27.1
| 2.27.1
|
| auth0 npm | < 2.27.1
| 2.27.1
|
Description
Overview
Versions before and including 2.27.0 use a block list of specific keys that should be sanitized from the request object contained in the error object. When a request to Auth0 management API fails, the key for Authorization header is not sanitized and the Authorization header value can be logged exposing a bearer token.
Am I affected?
You are affected by this vulnerability if all of the following conditions apply:
How to fix that?
Upgrade to version 2.27.1
Will this update impact my users?
The fix provided in patch will not affect your users.
Credit
http://github.com/osdiab
NVD description
In auth0 (npm package) versions before 2.27.1, a DenyList of specific keys that should be sanitized from the request object contained in the error object is used. The key for Authorization header is not sanitized and in certain cases the Authorization header value can be logged exposing a bearer token. You are affected by this vulnerability if you are using the auth0 npm package, and you are using a Machine to Machine application authorized to use Auth0's management API
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free