In short
- CVE-2020-25827 is a HIGH (CVSS 7.5) vulnerability affecting mediawiki/core, mediawiki (mediawiki).
- Chance of exploitation in the next 30 days (EPSS): 1.7%, higher than 77.3% of all vulnerabilities.
- Fix: update to 1.31.9, 1.34.3, 1.34.4, 1.31.10 or later.
| Package | Affected versions | Patched versions |
|---|
| mediawiki/core Packagist | ≥ 1.31.0, < 1.31.9≥ 1.32.0, < 1.34.3
| 1.31.91.34.3
|
| mediawiki | ≥ 1.32.0, < 1.34.4< 1.31.10
| 1.34.41.31.10
|
Description
An issue was discovered in the OATHAuth extension in MediaWiki before 1.31.9 and 1.32.x through 1.34.x before 1.34.3. For Wikis using OATHAuth on a farm/cluster (such as via CentralAuth), rate limiting of OATH tokens is only done on a single site level. Thus, multiple requests can be made across many wikis/sites concurrently.
NVD description
An issue was discovered in the OATHAuth extension in MediaWiki before 1.31.10 and 1.32.x through 1.34.x before 1.34.4. For Wikis using OATHAuth on a farm/cluster (such as via CentralAuth), rate limiting of OATH tokens is only done on a single site level. Thus, multiple requests can be made across many wikis/sites concurrently.
More vulnerabilities in mediawiki/core
See all →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free