In short
- CVE-2020-25828 is a MEDIUM (CVSS 6.1) vulnerability affecting mediawiki/core, mediawiki (mediawiki).
- Chance of exploitation in the next 30 days (EPSS): 1.1%, higher than 65.3% of all vulnerabilities.
- Fix: update to 1.31.9, 1.34.3, 1.35.0, 1.34.4 or later.
| Package | Affected versions | Patched versions |
|---|
| mediawiki/core Packagist | ≥ 1.31.0, < 1.31.9≥ 1.32.0, < 1.34.3≥ 1.35.0-rc.0, < 1.35.0
| 1.31.91.34.31.35.0
|
| mediawiki | = 1.31.10≥ 1.32.0, < 1.34.4
| 1.34.4
|
Description
An issue was discovered in MediaWiki before 1.31.9 and 1.32.x through 1.34.x before 1.34.3. The non-jqueryMsg version of mw.message().parse() doesn't escape HTML. This affects both message contents (which are generally safe) and the parameters (which can be based on user input). (When jqueryMsg is loaded, it correctly accepts only whitelisted tags in message contents, and escapes all parameters. Situations with an unloaded jqueryMsg are rare in practice, but can for example occur for Special:SpecialPages on a wiki with no extensions installed.)
NVD description
An issue was discovered in MediaWiki before 1.31.10 and 1.32.x through 1.34.x before 1.34.4. The non-jqueryMsg version of mw.message().parse() doesn't escape HTML. This affects both message contents (which are generally safe) and the parameters (which can be based on user input). (When jqueryMsg is loaded, it correctly accepts only whitelisted tags in message contents, and escapes all parameters. Situations with an unloaded jqueryMsg are rare in practice, but can for example occur for Special:SpecialPages on a wiki with no extensions installed.)
More vulnerabilities in mediawiki/core
See all →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free