In short
- CVE-2020-36327 is a HIGH (CVSS 8.8) vulnerability affecting bundler, bundler (bundler).
- Chance of exploitation in the next 30 days (EPSS): 6.3%, higher than 93.6% of all vulnerabilities.
- Fix: update to 2.2.10, 2.2.18 or later.
| Package | Affected versions | Patched versions |
|---|
| bundler RubyGems | ≥ 1.16.0, < 2.2.10≥ 2.2.11, < 2.2.18
| 2.2.102.2.18
|
| bundler | ≥ 1.16.0, < 2.2.10≥ 2.2.11, ≤ 2.2.16
| 2.2.10
|
Description
Bundler 1.16.0 through 2.2.9 and 2.2.11 through 2.2.17 sometimes chooses a dependency source based on the highest gem version number, which means that a rogue gem found at a public source may be chosen, even if the intended choice was a private gem that is a dependency of another private gem that is explicitly depended on by the application.
NVD description
Bundler 1.16.0 through 2.2.9 and 2.2.11 through 2.2.16 sometimes chooses a dependency source based on the highest gem version number, which means that a rogue gem found at a public source may be chosen, even if the intended choice was a private gem that is a dependency of another private gem that is explicitly depended on by the application. NOTE: it is not correct to use CVE-2021-24105 for every "Dependency Confusion" issue in every product.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free