In short
- CVE-2020-7610 is a CRITICAL (CVSS 9.8) vulnerability affecting bson (mongodb), bson.
- Chance of exploitation in the next 30 days (EPSS): 2.3%, higher than 83.0% of all vulnerabilities.
- Fix: update to 1.1.4 or later.
| Package | Affected versions | Patched versions |
|---|
| bson | ≥ 1.0.0, < 1.1.4
| 1.1.4
|
| bson npm | < 1.1.4
| 1.1.4
|
Description
All versions of bson before 1.1.4 are vulnerable to Deserialization of Untrusted Data. The package will ignore an unknown value for an object's _bsontype, leading to cases where an object is serialized as a document rather than the intended BSON type.
NVD description
All versions of bson before 1.1.4 are vulnerable to Deserialization of Untrusted Data. The package will ignore an unknown value for an object's _bsotype, leading to cases where an object is serialized as a document rather than the intended BSON type.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free