In short
- CVE-2020-7680 is a MEDIUM (CVSS 6.1) vulnerability affecting docsify (docsifyjs), docsify.
- Chance of exploitation in the next 30 days (EPSS): 4.5%, higher than 91.5% of all vulnerabilities.
- Fix: update to 4.11.4 or later.
| Package | Affected versions | Patched versions |
|---|
| docsify | < 4.11.4
| 4.11.4
|
| docsify npm | < 4.11.4
| 4.11.4
|
Description
docsify prior to 4.11.4 is susceptible to Cross-site Scripting (XSS). Docsify.js uses fragment identifiers (parameters after # sign) to load resources from server-side .md files. Due to lack of validation here, it is possible to provide external URLs after the /#/ (domain.com/#//attacker.com) and render arbitrary JavaScript/HTML inside docsify page.
NVD description
docsify prior to 4.11.4 is susceptible to Cross-site Scripting (XSS). Docsify.js uses fragment identifiers (parameters after # sign) to load resources from server-side .md files. Due to lack of validation here, it is possible to provide external URLs after the /#/ (domain.com/#//attacker.com) and render arbitrary JavaScript/HTML inside docsify page.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free