In short
- CVE-2021-23342 is a MEDIUM (CVSS 6.1) vulnerability affecting docsify (docsifyjs), docsify.
- Chance of exploitation in the next 30 days (EPSS): 1.7%, higher than 76.7% of all vulnerabilities.
- Fix: update to 4.12.0 or later.
| Package | Affected versions | Patched versions |
|---|
| docsify | < 4.12.0
| 4.12.0
|
| docsify npm | < 4.12.0
| 4.12.0
|
Description
This affects the package docsify before 4.12.0. It is possible to bypass the remediation done by CVE-2020-7680 and execute malicious JavaScript through the following methods 1) When parsing HTML from remote URLs, the HTML code on the main page is sanitized, but this sanitization is not taking place in the sidebar. 2) The isURL external check can be bypassed by inserting more //// characters
NVD description
This affects the package docsify before 4.12.0. It is possible to bypass the remediation done by CVE-2020-7680 and execute malicious JavaScript through the following methods 1) When parsing HTML from remote URLs, the HTML code on the main page is sanitized, but this sanitization is not taking place in the sidebar. 2) The isURL external check can be bypassed by inserting more “////” characters
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free