In short
- CVE-2020-7729 is a HIGH (CVSS 7.1) vulnerability affecting grunt (gruntjs), grunt.
- Chance of exploitation in the next 30 days (EPSS): 2.3%, higher than 83.4% of all vulnerabilities.
- Fix: update to 1.3.0 or later.
| Package | Affected versions | Patched versions |
|---|
| grunt | < 1.3.0
| 1.3.0
|
| grunt npm | < 1.3.0
| 1.3.0
|
Description
The package grunt before 1.3.0 are vulnerable to Arbitrary Code Execution due to the default usage of the function load() instead of its secure replacement safeLoad() of the package js-yaml inside grunt.file.readYAML.
NVD description
The package grunt before 1.3.0 are vulnerable to Arbitrary Code Execution due to the default usage of the function load() instead of its secure replacement safeLoad() of the package js-yaml inside grunt.file.readYAML.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free