In short
- CVE-2022-1537 is a HIGH (CVSS 7.0) vulnerability affecting grunt (gruntjs), grunt.
- Chance of exploitation in the next 30 days (EPSS): 0.30%, higher than 23.0% of all vulnerabilities.
- Fix: update to 1.5.3 or later.
| Package | Affected versions | Patched versions |
|---|
| grunt | < 1.5.3
| 1.5.3
|
| grunt npm | < 1.5.3
| 1.5.3
|
Description
file.copy operations in GruntJS are vulnerable to a TOCTOU race condition leading to arbitrary file write in GitHub repository gruntjs/grunt prior to 1.5.3. This vulnerability is capable of arbitrary file writes which can lead to local privilege escalation to the GruntJS user if a lower-privileged user has write access to both source and destination directories as the lower-privileged user can create a symlink to the GruntJS user's .bashrc file or replace /etc/shadow file if the GruntJS user is root.
NVD description
file.copy operations in GruntJS are vulnerable to a TOCTOU race condition leading to arbitrary file write in GitHub repository gruntjs/grunt prior to 1.5.3. This vulnerability is capable of arbitrary file writes which can lead to local privilege escalation to the GruntJS user if a lower-privileged user has write access to both source and destination directories as the lower-privileged user can create a symlink to the GruntJS user's .bashrc file or replace /etc/shadow file if the GruntJS user is root.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free