In short
- CVE-2020-8186 is a CRITICAL (CVSS 9.8) vulnerability affecting devcert (devcert project), devcert.
- Chance of exploitation in the next 30 days (EPSS): 2.8%, higher than 86.4% of all vulnerabilities.
- Fix: update to 1.1.2 or later.
| Package | Affected versions | Patched versions |
|---|
| devcert | = 1.1.0
| No fix yet |
| devcert npm | < 1.1.2
| 1.1.2
|
Description
A command injection vulnerability in the devcert module may lead to remote code execution when users of the module pass untrusted input to the certificateFor function.
NVD description
A command injection vulnerability in the `devcert` module may lead to remote code execution when users of the module pass untrusted input to the `certificateFor` function.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free