In short
- CVE-2022-1929 is a HIGH (CVSS 7.5) vulnerability affecting devcert (devcert project), devcert.
- Chance of exploitation in the next 30 days (EPSS): 0.64%, higher than 50.9% of all vulnerabilities.
- Fix: update to 1.2.1 or later.
| Package | Affected versions | Patched versions |
|---|
| devcert | < 1.2.1
| 1.2.1
|
| devcert npm | < 1.2.1
| 1.2.1
|
Description
An exponential ReDoS (Regular Expression Denial of Service) can be triggered in the devcert npm package, when an attacker is able to supply arbitrary input to the certificateFor method
NVD description
An exponential ReDoS (Regular Expression Denial of Service) can be triggered in the devcert npm package, when an attacker is able to supply arbitrary input to the certificateFor method
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free