In short
- CVE-2020-9487 is a HIGH (CVSS 7.5) vulnerability affecting org.apache.nifi:nifi, nifi (apache).
- Chance of exploitation in the next 30 days (EPSS): 3.0%, higher than 87.6% of all vulnerabilities.
- Fix: update to 1.12.0-RC1 or later.
| Package | Affected versions | Patched versions |
|---|
| org.apache.nifi:nifi Maven | ≥ 1.0.0, < 1.12.0-RC1
| 1.12.0-RC1
|
| nifi | ≥ 1.0.0, ≤ 1.11.4
| No fix yet |
Description
In Apache NiFi 1.0.0 to 1.11.4, the NiFi download token (one-time password) mechanism used a fixed cache size and did not authenticate a request to create a download token, only when attempting to use the token to access the content. An unauthenticated user could repeatedly request download tokens, preventing legitimate users from requesting download tokens.
NVD description
In Apache NiFi 1.0.0 to 1.11.4, the NiFi download token (one-time password) mechanism used a fixed cache size and did not authenticate a request to create a download token, only when attempting to use the token to access the content. An unauthenticated user could repeatedly request download tokens, preventing legitimate users from requesting download tokens.
More vulnerabilities in org.apache.nifi:nifi
See all →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free