In short
- CVE-2020-9491 is a HIGH (CVSS 7.5) vulnerability affecting org.apache.nifi:nifi, nifi (apache).
- Chance of exploitation in the next 30 days (EPSS): 2.9%, higher than 86.8% of all vulnerabilities.
- Fix: update to 1.12.0-RC1 or later.
| Package | Affected versions | Patched versions |
|---|
| org.apache.nifi:nifi Maven | ≥ 1.2.0, < 1.12.0-RC1
| 1.12.0-RC1
|
| nifi | ≥ 1.0.0, ≤ 1.11.4
| No fix yet |
Description
In Apache NiFi 1.2.0 to 1.11.4, the NiFi UI and API were protected by mandating TLS v1.2, as well as listening connections established by processors like ListenHTTP, HandleHttpRequest, etc. However intracluster communication such as cluster request replication, Site-to-Site, and load balanced queues continued to support TLS v1.0 or v1.1.
NVD description
In Apache NiFi 1.2.0 to 1.11.4, the NiFi UI and API were protected by mandating TLS v1.2, as well as listening connections established by processors like ListenHTTP, HandleHttpRequest, etc. However intracluster communication such as cluster request replication, Site-to-Site, and load balanced queues continued to support TLS v1.0 or v1.1.
More vulnerabilities in org.apache.nifi:nifi
See all →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free