In short
- CVE-2021-23566 is a MEDIUM (CVSS 5.5) vulnerability affecting nanoid (nanoid project), nanoid.
- Chance of exploitation in the next 30 days (EPSS): 0.47%, higher than 41.2% of all vulnerabilities.
- Fix: update to 3.1.31 or later.
| Package | Affected versions | Patched versions |
|---|
| nanoid | ≥ 3.0.0, < 3.1.31
| 3.1.31
|
| nanoid npm | ≥ 3.0.0, < 3.1.31
| 3.1.31
|
Description
The package nanoid from 3.0.0, before 3.1.31, are vulnerable to Information Exposure via the valueOf() function which allows to reproduce the last id generated.
NVD description
The package nanoid from 3.0.0 and before 3.1.31 are vulnerable to Information Exposure via the valueOf() function which allows to reproduce the last id generated.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free