In short
- CVE-2026-67213 is a HIGH (CVSS 7.5) vulnerability affecting nanoid (nanoid project), nanoid.
- Chance of exploitation in the next 30 days (EPSS): 0.33%, higher than 26.4% of all vulnerabilities.
- Fix: update to 3.3.17, 5.1.6, 3.3.18 or later.
| Package | Affected versions | Patched versions |
|---|
| nanoid | ≥ 3.0.0, < 3.3.17≥ 5.0.0, < 5.1.6
| 3.3.175.1.6
|
| nanoid npm | ≥ 4.0.0, < 5.1.6< 3.3.18
| 5.1.63.3.18
|
Description
nanoid (Nano ID) before 5.1.6 contains an infinite loop in the customAlphabet and customRandom functions. When these functions are configured with a size of 0, the internal generation loop never satisfies its exit condition and spins indefinitely, hanging the calling thread. An application that passes an unvalidated, attacker-controlled size of 0 to these functions is exposed to a denial-of-service condition.
NVD description
nanoid (Nano ID) before 5.1.6 contains an infinite loop in the customAlphabet and customRandom functions. When these functions are configured with a size of 0, the internal generation loop never satisfies its exit condition and spins indefinitely, hanging the calling thread. An application that passes an unvalidated, attacker-controlled size of 0 to these functions is exposed to a denial-of-service condition.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free