In short
- CVE-2021-25929 is a MEDIUM (CVSS 4.8) vulnerability affecting org.opennms:opennms, horizon (opennms), meridian (opennms).
- Chance of exploitation in the next 30 days (EPSS): 1.0%, higher than 63.4% of all vulnerabilities.
- Fix: update to 27.1.1, 2019.1.19, 2020.1.7 or later.
| Package | Affected versions | Patched versions |
|---|
| org.opennms:opennms Maven | ≥ 1.0.0, < 27.1.1
| 27.1.1
|
| horizon | ≥ 1.0, < 27.1.1
| 27.1.1
|
| meridian | ≥ 2015.1.0, < 2019.1.19≥ 2020.1.0, < 2020.1.7
| 2019.1.192020.1.7
|
Description
In OpenNMS Horizon, versions opennms-1-0-stable through opennms-27.1.1; OpenNMS Meridian, versions meridian-foundation-2015.1.0-1 through meridian-foundation-2019.1.18-1; meridian-foundation-2020.1.0-1 through meridian-foundation-2020.1.6-1 are vulnerable to Stored Cross-Site Scripting since there is no validation on the input being sent to the name parameter in noticeWizard endpoint. Due to this flaw an authenticated attacker could inject arbitrary script and trick other admin users into downloading malicious files.
NVD description
In OpenNMS Horizon, versions opennms-1-0-stable through opennms-27.1.0-1; OpenNMS Meridian, versions meridian-foundation-2015.1.0-1 through meridian-foundation-2019.1.18-1; meridian-foundation-2020.1.0-1 through meridian-foundation-2020.1.6-1 are vulnerable to Stored Cross-Site Scripting since there is no validation on the input being sent to the `name` parameter in `noticeWizard` endpoint. Due to this flaw an authenticated attacker could inject arbitrary script and trick other admin users into downloading malicious files.
More vulnerabilities in org.opennms:opennms
See all →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free