In short
- CVE-2021-25931 is a HIGH (CVSS 8.8) vulnerability affecting org.opennms:opennms, horizon (opennms), meridian (opennms).
- Chance of exploitation in the next 30 days (EPSS): 0.73%, higher than 54.1% of all vulnerabilities.
- Fix: update to 27.1.1, 2019.1.19, 2020.1.7 or later.
| Package | Affected versions | Patched versions |
|---|
| org.opennms:opennms Maven | ≥ 1.0.0, < 27.1.1
| 27.1.1
|
| horizon | ≥ 1.0, < 27.1.1
| 27.1.1
|
| meridian | ≥ 2015.1.0, < 2019.1.19≥ 2020.1.0, < 2020.1.7
| 2019.1.192020.1.7
|
Description
In OpenNMS Horizon, versions opennms-1-0-stable through opennms-27.1.1; OpenNMS Meridian, versions meridian-foundation-2015.1.0-1 through meridian-foundation-2019.1.18-1; meridian-foundation-2020.1.0-1 through meridian-foundation-2020.1.6-1 are vulnerable to CSRF, due to no CSRF protection at /opennms/admin/userGroupView/users/updateUser. This flaw allows assigning ROLE_ADMIN security role to a normal user. Using this flaw, an attacker can trick the admin user to assign administrator privileges to a normal user by enticing him to click upon an attacker-controlled website.
NVD description
In OpenNMS Horizon, versions opennms-1-0-stable through opennms-27.1.0-1; OpenNMS Meridian, versions meridian-foundation-2015.1.0-1 through meridian-foundation-2019.1.18-1; meridian-foundation-2020.1.0-1 through meridian-foundation-2020.1.6-1 are vulnerable to CSRF, due to no CSRF protection at `/opennms/admin/userGroupView/users/updateUser`. This flaw allows assigning `ROLE_ADMIN` security role to a normal user. Using this flaw, an attacker can trick the admin user to assign administrator privileges to a normal user by enticing him to click upon an attacker-controlled website.
More vulnerabilities in org.opennms:opennms
See all →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free