In short
- CVE-2021-25975 is a MEDIUM (CVSS 5.4) vulnerability affecting publify_core, publify (publify project).
- Chance of exploitation in the next 30 days (EPSS): 0.60%, higher than 48.6% of all vulnerabilities.
- Fix: update to 9.2.5 or later.
| Package | Affected versions | Patched versions |
|---|
| publify_core RubyGems | ≥ 8.0, < 9.2.5
| 9.2.5
|
| publify | ≥ 8.0, ≤ 9.2.4
| No fix yet |
Description
In publify, versions v8.0 to v9.2.4 are vulnerable to stored XSS as a result of an unrestricted file upload. This issue allows a user with “publisher” role to inject malicious JavaScript via the uploaded html file.
NVD description
In publify, versions v8.0 to v9.2.4 are vulnerable to stored XSS as a result of an unrestricted file upload. This issue allows a user with “publisher” role to inject malicious JavaScript via the uploaded html file.
More vulnerabilities in publify_core
See all →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free