In short
- CVE-2021-25986 is a MEDIUM (CVSS 5.4) vulnerability affecting wiki, django-wiki (django-wiki project).
- Chance of exploitation in the next 30 days (EPSS): 0.60%, higher than 49.0% of all vulnerabilities.
- Fix: update to 0.7.9 or later.
| Package | Affected versions | Patched versions |
|---|
| wiki PyPI | ≥ 0.0.20, < 0.7.9
| 0.7.9
|
| django-wiki | ≥ 0.0.20, ≤ 0.7.8
| No fix yet |
Description
In Django-wiki, versions 0.0.20 to 0.7.8 are vulnerable to Stored Cross-Site Scripting (XSS) in Notifications Section. An attacker who has access to edit pages can inject JavaScript payload in the title field. When a victim gets a notification regarding the changes made in the application, the payload in the notification panel renders and loads external JavaScript.
NVD description
In Django-wiki, versions 0.0.20 to 0.7.8 are vulnerable to Stored Cross-Site Scripting (XSS) in Notifications Section. An attacker who has access to edit pages can inject JavaScript payload in the title field. When a victim gets a notification regarding the changes made in the application, the payload in the notification panel renders and loads external JavaScript.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free