In short
- CVE-2024-28865 is a HIGH (CVSS 7.5) vulnerability affecting wiki, django-wiki (django-wiki project).
- Chance of exploitation in the next 30 days (EPSS): 0.61%, higher than 49.4% of all vulnerabilities.
- Fix: update to 0.10.1 or later.
| Package | Affected versions | Patched versions |
|---|
| wiki PyPI | < 0.10.1
| 0.10.1
|
| django-wiki | < 0.10.1
| 0.10.1
|
Description
Impact
All historical installations of django-wiki are vulnerable to maliciously crafted article content, that can cause severe use of server CPU through a regular expression loop.
Patches
Workarounds
Close off access to create and edit articles by anonymous users.
References
Are there any links users can visit to find out more?
NVD description
django-wiki is a wiki system for Django. Installations of django-wiki prior to version 0.10.1 are vulnerable to maliciously crafted article content that can cause severe use of server CPU through a regular expression loop. Version 0.10.1 fixes this issue. As a workaround, close off access to create and edit articles by anonymous users.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free