In short
- CVE-2021-25987 is a MEDIUM (CVSS 4.6) vulnerability affecting hexo (hexo), hexo.
- Chance of exploitation in the next 30 days (EPSS): 0.34%, higher than 27.4% of all vulnerabilities.
- Fix: update to 6.0.0 or later.
| Package | Affected versions | Patched versions |
|---|
| hexo | ≥ 0.0.1, ≤ 5.4.0
| No fix yet |
| hexo npm | ≥ 0.0.1, < 6.0.0
| 6.0.0
|
Description
Hexo versions 0.0.1 to 5.4.0 are vulnerable against stored XSS. The post “body” and “tags” don’t sanitize malicious javascript during web page generation. Local unprivileged attacker can inject arbitrary code.
NVD description
Hexo versions 0.0.1 to 5.4.0 are vulnerable against stored XSS. The post “body” and “tags” don’t sanitize malicious javascript during web page generation. Local unprivileged attacker can inject arbitrary code.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free