In short
- CVE-2021-26120 is a CRITICAL (CVSS 9.8) vulnerability affecting smarty/smarty, smarty (smarty).
- Chance of exploitation in the next 30 days (EPSS): 82.3%, higher than 99.7% of all vulnerabilities.
- Fix: update to 3.1.39 or later.
| Package | Affected versions | Patched versions |
|---|
| smarty/smarty Packagist | < 3.1.39
| 3.1.39
|
| smarty | < 3.1.39
| 3.1.39
|
Description
Template authors could inject php code by choosing a malicous {function} name. Sites that cannot fully trust template authors should update as soon as possible. Please upgrade to 3.1.39 or higher.
NVD description
Smarty before 3.1.39 allows code injection via an unexpected function name after a {function name= substring.
More vulnerabilities in smarty/smarty
See all →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free