In short
- CVE-2021-27515 is a MEDIUM (CVSS 5.3) vulnerability affecting url-parse (url-parse project), url-parse.
- Chance of exploitation in the next 30 days (EPSS): 2.0%, higher than 80.4% of all vulnerabilities.
- Fix: update to 1.5.0 or later.
| Package | Affected versions | Patched versions |
|---|
| url-parse | < 1.5.0
| 1.5.0
|
| url-parse npm | ≥ 0.1.0, < 1.5.0
| 1.5.0
|
Description
url-parse before 1.5.0 mishandles certain uses of backslash such as http:/ and interprets the URI as a relative path.
NVD description
url-parse before 1.5.0 mishandles certain uses of backslash such as http:\/ and interprets the URI as a relative path.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free