In short
- CVE-2022-0512 is a MEDIUM (CVSS 5.3) vulnerability affecting url-parse (url-parse project), url-parse.
- Chance of exploitation in the next 30 days (EPSS): 1.8%, higher than 78.3% of all vulnerabilities.
- Fix: update to 1.5.6 or later.
| Package | Affected versions | Patched versions |
|---|
| url-parse | < 1.5.6
| 1.5.6
|
| url-parse npm | ≥ 0.1.0, < 1.5.6
| 1.5.6
|
Description
Authorization Bypass Through User-Controlled Key in NPM url-parse prior to 1.5.6.
NVD description
Authorization Bypass Through User-Controlled Key in NPM url-parse prior to 1.5.6.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free