In short
- CVE-2021-29943 is a CRITICAL (CVSS 9.1) vulnerability affecting org.apache.solr:solr-parent, solr (apache).
- Chance of exploitation in the next 30 days (EPSS): 4.7%, higher than 91.8% of all vulnerabilities.
- Fix: update to 8.8.2 or later.
Description
When using ConfigurableInternodeAuthHadoopPlugin for authentication, Apache Solr versions prior to 8.8.2 would forward/proxy distributed requests using server credentials instead of original client credentials. This would result in incorrect authorization resolution on the receiving hosts.
NVD description
When using ConfigurableInternodeAuthHadoopPlugin for authentication, Apache Solr versions prior to 8.8.2 would forward/proxy distributed requests using server credentials instead of original client credentials. This would result in incorrect authorization resolution on the receiving hosts.
More vulnerabilities in org.apache.solr:solr-parent
See all →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free