In short
- CVE-2021-30151 is a MEDIUM (CVSS 6.1) vulnerability affecting sidekiq, sidekiq (contribsys).
- Chance of exploitation in the next 30 days (EPSS): 4.2%, higher than 90.9% of all vulnerabilities.
- Fix: update to 6.2.1, 5.2.0 or later.
| Package | Affected versions | Patched versions |
|---|
| sidekiq RubyGems | ≥ 6.0.0, < 6.2.1< 5.2.0
| 6.2.15.2.0
|
| sidekiq | ≥ 6.0.0, ≤ 6.2.0≤ 5.1.3
| No fix yet |
Description
Sidekiq through 5.1.3 and 6.x through 6.2.0 allows XSS via the queue name of the live-poll feature when Internet Explorer is used.
NVD description
Sidekiq through 5.1.3 and 6.x through 6.2.0 allows XSS via the queue name of the live-poll feature when Internet Explorer is used.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free