In short
- CVE-2023-1892 is a CRITICAL (CVSS 9.6) vulnerability affecting sidekiq, sidekiq (contribsys).
- Chance of exploitation in the next 30 days (EPSS): 2.7%, higher than 86.2% of all vulnerabilities.
- Fix: update to 7.0.8 or later.
| Package | Affected versions | Patched versions |
|---|
| sidekiq RubyGems | ≥ 7.0.4, < 7.0.8
| 7.0.8
|
| sidekiq | ≥ 7.0.4, < 7.0.8
| 7.0.8
|
Description
sidekiq from 7.0.4 to 7.0.7 is vulnerable to reflected cross-site scripting. A fix was released in version 7.0.8.
NVD description
Cross-site Scripting (XSS) - Reflected in GitHub repository sidekiq/sidekiq prior to 7.0.8.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free