In short
- CVE-2021-3313 is a MEDIUM (CVSS 5.4) vulnerability affecting plone, plone (plone).
- Chance of exploitation in the next 30 days (EPSS): 0.98%, higher than 62.2% of all vulnerabilities.
- Fix: update to 5.2.4 or later.
| Package | Affected versions | Patched versions |
|---|
| plone PyPI | < 5.2.4
| 5.2.4
|
| plone | < 5.2.4
| 5.2.4
|
Description
Plone CMS until version 5.2.4 has a stored Cross-Site Scripting (XSS) vulnerability in the user fullname property and the file upload functionality. The user's input data is not properly encoded when being echoed back to the user. This data can be interpreted as executable code by the browser and allows an attacker to execute JavaScript in the context of the victim's browser if the victim opens a vulnerable page containing an XSS payload.
NVD description
Plone CMS until version 5.2.4 has a stored Cross-Site Scripting (XSS) vulnerability in the user fullname property and the file upload functionality. The user's input data is not properly encoded when being echoed back to the user. This data can be interpreted as executable code by the browser and allows an attacker to execute JavaScript in the context of the victim's browser if the victim opens a vulnerable page containing an XSS payload.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free