In short
- CVE-2021-33587 is a HIGH (CVSS 7.5) vulnerability affecting css-what (css-what project), css-what.
- Chance of exploitation in the next 30 days (EPSS): 2.0%, higher than 81.2% of all vulnerabilities.
- Fix: update to 5.0.1 or later.
| Package | Affected versions | Patched versions |
|---|
| css-what | = 4.0.0= 5.0.0
| No fix yet |
| css-what npm | ≥ 4.0.0, < 5.0.1
| 5.0.1
|
Description
The css-what package 4.0.0 through 5.0.0 for Node.js does not ensure that attribute parsing has Linear Time Complexity relative to the size of the input.
NVD description
The css-what package 4.0.0 through 5.0.0 for Node.js does not ensure that attribute parsing has Linear Time Complexity relative to the size of the input.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free