In short
- CVE-2022-21222 is a HIGH (CVSS 7.5) vulnerability affecting css-what (css-what project), css-what.
- Chance of exploitation in the next 30 days (EPSS): 1.9%, higher than 79.8% of all vulnerabilities.
- Fix: update to 2.1.3 or later.
| Package | Affected versions | Patched versions |
|---|
| css-what | < 2.1.3
| 2.1.3
|
| css-what npm | < 2.1.3
| 2.1.3
|
Description
The package css-what before 2.1.3 is vulnerable to Regular Expression Denial of Service (ReDoS) due to the use of insecure regular expression in the re_attr variable of index.js. The exploitation of this vulnerability could be triggered via the parse function.
NVD description
The package css-what before 2.1.3 are vulnerable to Regular Expression Denial of Service (ReDoS) due to the usage of insecure regular expression in the re_attr variable of index.js. The exploitation of this vulnerability could be triggered via the parse function.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free