In short
- CVE-2021-45082 is a HIGH (CVSS 7.8) vulnerability affecting cobbler, cobbler (cobbler project).
- Chance of exploitation in the next 30 days (EPSS): 0.50%, higher than 42.5% of all vulnerabilities.
- Fix: update to 3.3.1 or later.
| Package | Affected versions | Patched versions |
|---|
| cobbler PyPI | < 3.3.1
| 3.3.1
|
| cobbler | < 3.3.1
| 3.3.1
|
Description
An issue was discovered in Cobbler through 3.3.0. In the templar.py file, the function check_for_invalid_imports can allow Cheetah code to import Python modules via the "#from MODULE import" substring. (Only lines beginning with #import are blocked.)
NVD description
An issue was discovered in Cobbler before 3.3.1. In the templar.py file, the function check_for_invalid_imports can allow Cheetah code to import Python modules via the "#from MODULE import" substring. (Only lines beginning with #import are blocked.)
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free