In short
- CVE-2022-21829 is a CRITICAL (CVSS 9.8) vulnerability affecting concrete5/core, concrete cms (concretecms).
- Chance of exploitation in the next 30 days (EPSS): 1.8%, higher than 78.1% of all vulnerabilities.
- Fix: update to 9.1.0, 8.5.8 or later.
| Package | Affected versions | Patched versions |
|---|
| concrete5/core Packagist | ≥ 9.0.0, < 9.1.0< 8.5.8
| 9.1.08.5.8
|
| concrete cms | ≥ 9.0.0, < 9.1.0< 8.5.8
| 9.1.08.5.8
|
Description
Concrete CMS Versions 9.0.0 through 9.0.2 and 8.5.7 and below can download zip files over HTTP and execute code from those zip files which could lead to an RCE. Fixed by enforcing ‘concrete_secure’ instead of ‘concrete’. Concrete now only makes requests over https even a request comes in via http. Concrete CMS security team ranked this 8 with CVSS v3.1 vector: AV:N/AC:H/PR:H/UI:N/S:C/C:H/I:H/A:H Credit goes to Anna for reporting HackerOne 1482520.
NVD description
Concrete CMS Versions 9.0.0 through 9.0.2 and 8.5.7 and below can download zip files over HTTP and execute code from those zip files which could lead to an RCE. Fixed by enforcing ‘concrete_secure’ instead of ‘concrete’. Concrete now only makes requests over https even a request comes in via http. Concrete CMS security team ranked this 8 with CVSS v3.1 vector: AV:N/AC:H/PR:H/UI:N/S:C/C:H/I:H/A:H Credit goes to Anna for reporting HackerOne 1482520.
More vulnerabilities in concrete5/core
See all →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free