In short
- CVE-2022-30117 is a CRITICAL (CVSS 9.1) vulnerability affecting concrete5/core, concrete cms (concretecms).
- Chance of exploitation in the next 30 days (EPSS): 2.1%, higher than 81.9% of all vulnerabilities.
- Fix: update to 9.1.0, 8.5.8 or later.
| Package | Affected versions | Patched versions |
|---|
| concrete5/core Packagist | ≥ 9.0.0, < 9.1.0< 8.5.8
| 9.1.08.5.8
|
| concrete cms | ≥ 9.0.0, < 9.1.0< 8.5.8
| 9.1.08.5.8
|
Description
Concrete 8.5.7 and below as well as Concrete 9.0 through 9.0.2 allow traversal in /index.php/ccm/system/file/upload which could result in an Arbitrary File Delete exploit. This was remediated by sanitizing /index.php/ccm/system/file/upload to ensure Concrete doesn’t allow traversal and by changing isFullChunkFilePresent to have an early false return when input doesn't match expectations.Concrete CMS Security team ranked this 5.8 with CVSS v3.1 vector AV:N/AC:H/PR:H/UI:N/S:C/C:N/I:N/A:H. Credit to Siebene for reporting.
NVD description
Concrete 8.5.7 and below as well as Concrete 9.0 through 9.0.2 allow traversal in /index.php/ccm/system/file/upload which could result in an Arbitrary File Delete exploit. This was remediated by sanitizing /index.php/ccm/system/file/upload to ensure Concrete doesn’t allow traversal and by changing isFullChunkFilePresent to have an early false return when input doesn't match expectations.Concrete CMS Security team ranked this 5.8 with CVSS v3.1 vector AV:N/AC:H/PR:H/UI:N/S:C/C:N/I:N/A:H. Credit to Siebene for reporting.
More vulnerabilities in concrete5/core
See all →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free